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Small Print
The information in this help file is furnished for informational use only. Roger Smith, Margueritta Brigance, and 
Roger Smith Software assume no responsibility or liability for any errors or inaccuracies that may appear in this 
file.

The software described in this file is furnished under license and may only be used and copied in accordance 
with the terms of the license.

See also: License and Warranty Information



License and Warranty Information
StitchView Demo is a copyrighted program.    Since it is a demo of the full commercial version of StitchView, it 
may be uploaded to any BBS or online service as long as the complete, unmodified, program is included.

The StitchView Demonstration is copyrighted. The StitchView Demonstration is owned by Roger Smith and 
Margueritta Brigance and is protected by copyright laws and treaties. The StitchView Demonstration is offered 
with no warranty.

The StitchView Demonstration is freely available. You may make copies and distribute StitchView 
Demonstration as long as you follow this license agreement.

Under this license you may:

· use the StitchView Demonstration
· make unmodified copies of the StitchView Demonstration for use by another party

You may not:

· use, copy, modify, or transfer copies of the StitchView Demonstration except as provided in this license
· reverse engineer or decompile the StitchView Demonstration executable files
· sublicense, rent, lease, or assign the StitchView Demonstration
· sell the StitchView Demonstration (although a nominal charge for copying or online access may be charged
as long as the recipient is aware that the charge is not for the purchase of the StitchView Demonstration or 
StitchView).

Pfaff and PC-Designer are trademarks of Pfaff. StitchView and Oratorio are trademarks of Roger Smith 
Software.    RSBBS and RSBBS/Oratorio are service marks of Roger Smith Software. Other product names are 
trademarks of their respective companies.

Copyright    1994-1995 by Roger Smith and Margueritta Brigance.    Published by Roger Smith Software, P.O. 
Box 3745, Winter Springs, FL 32708. All Rights Reserved.



Introduction
StitchView displays and prints designs stored in Pfaff Creative Designer stitch files. StitchView displays both 
standard nine millimeter (.PCD) designs and "maxi" (.PCQ) designs.

StitchViews features include:

Displaying stitch files using Normal, Full, or Actual Size view modes.

Printing stitch files using None, Normal, Full, Actual Size, or Programming Sheet styles.

Saving a design in a binary or text stitch file.

Creating a text file from a design in the format used to exchange designs using online services like Prodigy.

Importing designs from text files such as those downloaded from Prodigy.

Copying a design to and importing designs from the Windows Clipboard.



System Requirements
To use StitchView you need the following:

a) An IBM PC or compatible computer
b) Microsoft Windows 3.1 or a compatible operating system
c) At least 2 megabytes of memory
d) At least 2 megabytes of free disk space



Using StitchView
To use StitchView you must be familiar with using Windows. See the Windows Users Guide if you need help 
with basic Windows concepts such as moving and resizing windows.

To run StitchView, double-click the StitchView icon. The Main window will be displayed

The Main window includes the pull-down menus, the design display area, and buttons for opening (loading) a 
stitch file, printing the displayed design, and exiting the program.

See also: Viewing Stitch Files
Changing the View Mode
Changing the Display Options
Printing Designs
Saving Designs
Importing Designs
Copying Stitch File Images to Other Programs
Copying and Pasting Designs



Getting Help
Help is available at any time when StitchView is running. Press the F1 key or select Contents from the Help 
menu.

Pressing F1 displays the help topic based on what you are currently doing in StitchView. 



Viewing Stitch Files
To view the design in a stitch file, click on the Open button at the bottom of the Main window or Select Open 
from the File menu or press Control-O (hold down the    key and press the letter O key).    The Open Stitch File 
window will be displayed. 

Select a PCD or PCQ file to display then press the Return key or click the OK button. The selected files design 
will be displayed in the Main window.

The Preview checkbox (under the Cancel button) is used to turn the preview of the selected design on or off.    
When the box is checked, a small image of the currently selected design is drawn in the preview area.    As you 
select different files, the preview image is updated. If the preview option is too slow on your computer, turn it off
by clicking the Preview checkbox.

See also: Changing the View Mode



Changing the View Mode
A design may be viewed in Normal, Full, or Actual Size mode. To change the mode, select the desired mode 
from the View menu.

See also: Normal Mode
Full Mode
Actual Size Mode



Normal Mode
The Normal Mode displays the design using the full height of the display area.    If the design is too wide to fit 
in the display area, a scroll bar is displayed below the window. The scroll bar can be used to move the design left
and right within the display area.

See also: Full Mode
Actual Size Mode



Full Mode
The Full Mode shrinks the design, if necessary, so that it is fully displayed in the display area. If the design is 
too wide to fit in the display area, the height of the design is reduced until the full width of the design is visible.

See also: Normal Mode
Actual Size Mode



Actual Size Mode
The Actual Size Mode attempts to display the design at the actual size that will be stitched.

Because of differences among monitors and display drivers, the size of the displayed design may not be exactly 
the same as the actual stitch size.

See also: Normal Mode
Full Mode



Changing the Display Options
Several display options are available under the Options menu. Using the Options menu you may turn on or off 
the display of statistics, the grid, use of double-width lines, highlighting of the initial point or last point, 
highlighting of all points, and other settings (Preferences).

See also: Statistics
View Grid
Double-Width Lines
Show Initial Point
Show Last Point
Show Points
Preferences



Statistics
Selecting the Statistics option of the Options menu turns on or off the statistics which are displayed to the right 
of the design. The statistics include the design type, size, and number of points.

The design size is displayed in millimeters (mm) or inches (in).    Use the Preferences option of the Options 
menu to change the units to millimeters or inches.

See also: View Grid
Double-Width Lines
Show Initial Point
Show Last Point
Show Points
Preferences



View Grid
Selecting the View Grid option of the Options menu turns on or off the grid which is displayed behind the 
design. The grid is drawn every two stitch units for PCD files and every eight stitch units for PCQ files. A stitch 
unit is equal to 1/6 millimeter when stitched by the sewing machine.

See also: Statistics
Double-Width Lines
Show Initial Point
Show Last Point
Show Points
Preferences



Double-Width Lines
Selecting the Double-Width Lines option of the Options menu turns double-width (bold) lines on and off. 
When the Double Width Lines option is on, bold lines are used to draw the design. 

Some designs are easier to see when the size of the displayed lines is changed. 

See also: Statistics
View Grid
Show Initial Point
Show Last Point
Show Points
Preferences



Show Initial Point
Selecting the Show Initial Point option of the Options menu turns highlighting of the initial (starting) point of 
the design on and off. When the Show Initial Point option is on, the initial point of the design is highlighted 
with a colored square (the color of the square is set by using the Preferences option of the Options menu).

See also: Statistics
View Grid
Show Last Point
Double-Width Lines
Show Points
Preferences



Show Last Point
Selecting the Show Last Point option of the Options menu turns highlighting of the initial (ending) point of the 
design on and off. When the Show Last Point option is on, the last point of the design is highlighted with a 
colored square (the color of the square is set by using the Preferences option of the Options menu).

See also: Statistics
View Grid
Show Initial Point
Double-Width Lines
Show Points
Preferences



Show Points
Selecting the Show Points option of the Options menu turns highlighting of the points on and off. When the 
Show Points option is on, the points of the design are highlighted with colored squares (the color of the squares 
is set by using the Preferences option of the Options menu).

See also: Statistics
View Grid
Double-Width Lines
Show Initial Point
Preferences



Preferences
Selecting the Preferences option of the Options menu displays a form allowing you to change various options.    
You can set the display colors of the background, lines, and points.    You can set the location and size of the 
Main Window buttons.    You can set the length of the lines in text files produced by the Save As option of the 
Main menu.    You can also set the units for the Statistics display.

See also: Statistics
View Grid
Double-Width Lines
Show Initial Point
Show Last Point
Show Points
Save As



Printing Designs
The displayed design may be printed by selecting the Print option from the File menu or by clicking on the 
Print button. The Print Stitch window is displayed. This window allows you to select the style of the printout. 
Use the Picture Style buttons to select the picture style and the check boxes to select other print options. 

The preview displayed in the upper-left corner of the Print Stitch window displays a rough image of the layout 
of the printout that will be produced. It is updated each time you change the picture style or a print option.

Click on the Printer Setup button to select a different printer or to change the setup of the printer. The options 
available will depend on your printer and driver. Some printers will offer the choice of portrait or landscape 
output. StitchView expects the printer to be set for portrait mode except when printing a Programming Sheet. 

Because the width of a programming sheet is almost the same width as a standard page, some printers will not be
able to print the cut-line around the Programming Sheet in portrait mode.    Therefore, you may wish to switch 
your printer to landscape mode before printing a Programming Sheet.

See also: Picture Styles
Print Options



Picture Styles

StitchView will print the design using one of five picture styles    None, Normal, Full, Actual Size, or 
Programming Sheet.

See also: Picture Style - None
Picture Style - Normal
Picture Style - Full
Picture Style - Actual Size
Picture Style - Programming Sheet



None
No picture is printed when the None option is selected.

See also: Picture Style - Normal
Picture Style - Full
Picture Style - Actual Size
Picture Style - Programming Sheet



Normal
When the Normal option is selected, the design is printed about three inches high at the top of the page.    If the 
design is too wide to fit on the page, the right edge of the design is cut off.

See also: Picture Style - None
Picture Style - Full
Picture Style - Actual Size
Picture Style - Programming Sheet



Full
When the Full option is selected, the designs height is reduced, if necessary, to fit the entire width of the design 
on the page.

See also: Picture Style - None
Picture Style - Normal
Picture Style - Actual Size
Picture Style - Programming Sheet



Actual Size
When the Actual Size option is selected, the design is printed approximately the same size that it will be 
stitched.    The size printed may vary from the actual stitch size because of differences in printers and printer 
drivers.

See also: Picture Style - None
Picture Style - Normal
Picture Style - Full
Picture Style - Programming Sheet



Programming Sheet
The Programming Sheet option is only available for nine millimeter (.PCD) designs. When the Programming 
Sheet option is selected, the design is printed to closely match the size of a Pfaff Creative Designer 
Programming Sheet. 

Some printers will print the Programming Sheet more accurately in landscape mode. Click the Printer Setup 
button and select the landscape option if it is available.

Because some printers are unable to print to the edge of the page, the Programming Sheet is printed in the center 
of the page and is surrounded by a dotted cut-line. The cut-line indicates where to cut or fold the paper to match 
the size of a Programming Sheet.

See also: Picture Style - None
Picture Style - Normal
Picture Style - Full
Picture Style - Actual Size



Print Options
In addition to selecting a picture style, the Print Stitch window allows you to select several other print options. 
The print options which are available vary depending on the selected picture format. For example, the Show 
Grid option is not available when the picture style is set to Actual since the grid would be too small.

See also: Show Grid
Show Initial Point
Show Last Point
Show Points
Show Border
Gray Background
Show Filename
List Points
Line Width



Show Grid
When the Show Grid option is on, a grid is drawn behind the design. The grid is drawn every two stitch units for
PCD files and every eight stitch units for PCQ files. A stitch unit is equal to 1/6 millimeter when stitched by the 
sewing machine.

See also: Show Initial Point
Show Last Point
Show Points
Show Border
Gray Background
Show Filename
List Points
Line Width



Show Initial Point
When the Show Initial Point option is on, the initial point of the design is highlighted by drawing a filled square
around the point.

See also: Show Grid
Show Last Point
Show Points
Show Border
Gray Background
Show Filename
List Points
Line Width



Show Last Point
When the Show Last Point option is on, the last point of the design is highlighted by drawing a filled circle 
around the point.

See also: Show Grid
Show Initial Point
Show Points
Show Border
Gray Background
Show Filename
List Points
Line Width



Show Points
When the Show Points option is on, all the points are highlighted by drawing a hollow square around the points.

See also: Show Grid
Show Initial Point
Show Last Point
Show Border
Gray Background
Show Filename
List Points
Line Width



Show Border
When the Show Border option is on, a border is drawn around the picture.

See also: Show Grid
Show Initial Point
Show Last Point
Show Points
Gray Background
Show Filename
List Points
Line Width



Gray Background
When the Gray Background option is on, the background of the picture is printed in gray.

See also: Show Grid
Show Initial Point
Show Last Point
Show Points
Show Border
Show Filename
List Points
Line Width



Show File Name
When the Show File Name option is on, the file name of the design file is printed at the top of the page.

See also: Show Grid
Show Initial Point
Show Points
Show Border
Gray Background
List Points
Line Width



List Points
When the List Points option is on, the points of the design are listed.

See also: Show Grid
Show Initial Point
Show Points
Show Border
Gray Background
Show Filename
Line Width



Line Width
The Line Width setting specifies the width of the printed stitch lines.    The width is specified in pixels.    The 
size of a pixel depends on your printer.    In general, use a setting of 1 or 2 for thin lines and 5 for thick lines..

See also: Show Grid
Show Initial Point
Show Points
Show Border
Gray Background
Show Filename
List Points



Copying Stitch File Images to Other Programs
Select the Copy Picture option of the Edit menu or press control-C to copy the image in the display area to the 
Windows clipboard. Once the image is in the clipboard, it may be pasted into other Windows programs.

Use the Paste option of the other Windows program to retrieve the image.

The image may be pasted into any application which supports the pasting of Windows bitmaps. For example, the
image may be pasted into the Windows Paintbrush program.



Copying and Pasting Designs
Copy Text

Select the Copy Text option of the Edit menu to copy the current design into the Windows clipboard. The design
is converted to text containing a list of the design points. The format is the same as the one used to exchange 
designs in online conferences such as those offered by Prodigy.

Once you have selected Copy Text to copy the design, you can paste the text into any Windows program that 
supports pasting of text. For example, if you use America Online (AOL), you can paste a design into a message 
by choosing the Paste option from AOL's Edit menu when you are editing the message.

Paste

Select the Paste option of the Edit menu to paste a design (or designs) from the clipboard into StitchView. The 
design(s) in the clipboard must be in the same format used to exchange designs in online conferences as 
described above. When you select the Paste option, the StitchView Import utility is used to read the clipboard 
text and to import (or save) the designs.

The Import Design window will be displayed. StitchView searches the clipboard text and displays a preview of
the first design it finds. If more than one design was found, a scroll bar is displayed. Use the scroll bar to select a 
design.    Press the Save As button to convert the displayed design to a binary or text stitch file (see Save As).    
Press the Paste button to load the design into StitchView.    Or press the Close button to exit the Import Design 
window.

Note: StitchView is not able to display a design if the text of the design is divided in the clipboard text. For 
example, if the design was spread among several messages and you copied the messages to the clipboard, 
StitchView will probably only display the beginning of the design.    Paste the text into an editor such as 
Window's notepad and use Notepad to remove the message headers and other text that are inside the design in 
the text.    Save the text into a file then use StitchView's Import utility (select the Import option of the File 
menu) to import the edited file.

The preview of the design is limited to 1000 points. If the design consists of more than 1000 points, the preview 
only shows the first 1000 points, but the Save As and Paste buttons will process all the points in the design.



Exporting Designs
A design may be saved as a binary or text stitch file or as a text file.    When the design is displayed, select Save 
As from the File menu. The Save As window is displayed. Select the type of file to save from the list in the 
bottom left corner of the window then enter the name of the file to create or select an existing file to replace. 
Click the OK button to save the design in the specified file.

The binary stitch files (Binary PCD and Binary PCQ) are created using the new stitch file format which was 
introduced by Pfaffs PC-Designer 3 software. Text stitch files (Text PCD and Text PCQ) use the classic stitch 
file format as used by earlier versions of the PC-Designer software.

You can use StitchView to convert PCD (9mm) designs to PCQ (maxi) designs and vice versa. If the design is 
less than or equal to 9mm in width, you are given the option to save it as a PCD (9mm) text or binary file even if 
the design was originally loaded as a PCQ (maxi) design. Designs originally loaded as PCD (9mm) designs may 
be saved as PCQ (maxi) designs.

Text Files are saved in a format which is used to exchange designs in online forums such as the Pfaff conference 
on Prodigy.    To load a text file back into StitchView use the Import option of the File menu.



Importing Designs
StitchView can import designs from text files. StitchView looks for designs in the format which is commonly 
used to exchange designs in online forums such as the Pfaff conference on Prodigy.

StitchView makes it easy to extract designs from the text of messages downloaded from Prodigy and other 
online services.    Capture the messages to a text file then use StitchViews import option to import the designs.

To import a design, select the Import option of the File menu. Select the text file containing the embedded 
designs.

The Import Design window will be displayed. StitchView searches the text file and displays a preview of the 
first design it finds. If more than one design was found, a scroll bar is displayed. Use the scroll bar to select a 
design from the file.    Press the Save As button to convert the displayed design to a binary or text stitch file (see 
Save As).    Press the Import button to load the design into StitchView.    Or press the Close button to exit the 
Import Design window.

Note: StitchView is not able to display a design if the text of the design is divided in the text file. For example, 
if the design was spread among several messages, StitchView will probably only display the beginning of the 
design.    Edit the file and remove the message headers and other text that is inside the design in the text file.    
Then import the editted file.

The preview of the design is limited to 1000 points. If the design consists of more than 1000 points, the preview 
only shows the first 1000 points, but the Save As and Import buttons will process all the points in the design.



Troubleshooting
Display Problems

The most likely cause of display problems (i.e. broken lines, random spots in the display, or black lines running 
through the display) is a bad or outdated display driver.    If you have any of these problems, please contact the 
manufacturer of your display card for updated Windows drivers. Corrupted images created by using the Copy 
Picture option of the Edit menu are also a symptom of a faulty display driver.

Installation Problems

If the installation program continually prompts you to insert the installation disk and the proper disk is the one in
the drive, try selecting "Cancel" to exit the install.    Then select "Run" from the Program Manager's "File" 
manager. Type "SETUP1.EXE" and press Return or click the OK button.    The installation program will restart.

Printing Problems

If you have a problem printing, make sure that the proper printer driver is installed and that the proper printer 
and printer port are selected. Make sure that the selected printer supports graphics. StitchView is unable to print
to text-only printers.

See also: Technical Support



Technical Support
Technical support for StitchView is available through U.S. mail and electronic mail.

The mailing address for technical support is:

Roger Smith Software
P.O. Box 3745
Winter Springs, FL    32708

Internet Electronic mail (e-mail) may be addressed to rasmith@aol.com.

Please include a description of the problem and a description of your computer.






